OpenTelemetry.PersistentStorage.FileSystem
by: OpenTelemetry Authors
- 47 total downloads
- Latest version: 1.1.1
OpenTelemetry Persistent Storage
PCLCrypto
by: Andrew Arnott
- 364 total downloads
- Latest version: 2.1.40-alpha
PCL Crypto provides a consistent, portable set of crypto APIs for .NET 4.5, Windows Store, Xamarin.iOS, Xamarin.Android. This makes it easier to create cross-platform .NET libraries and apps. Crypto functionality includes asymmetric and symmetric encryption and signatures, and key derivation. PCLCrypto calls into each native platform's crypto API for maximum performance. For RSA operations this produces a 2-100X improvement in performance on Android and iOS over using the standard RSACryptoServiceProvider API.
PCLStorage
by: Daniel Plaisted
- 169 total downloads
- Latest version: 1.0.2
PCL Storage provides a consistent, portable set of local file IO APIs for .NET, Windows Phone, Windows Store, Xamarin.iOS, Xamarin.Android, and Silverlight. This makes it easier to create cross-platform .NET libraries and apps.
PdfiumViewer
by: Pieter van Ginkel
- 298 total downloads
- Latest version: 2.13.0
PDF viewer based on the PDFium project.
PdfiumViewer.Native.x86.v8-xfa
by: Pieter van Ginkel
- 472 total downloads
- Latest version: 2018.4.8.256
Native 32-bit PDFium DLL with V8 and XFA support for usage with the PdfiumViewer project.
PdfPig
by: UglyToad
- 3.467k total downloads
- Latest version: 0.1.17-alpha-202609280041-db596
Reads text content from PDF documents and supports document creation. Apache 2.0 licensed.
PDFsharp
by: PDFsharp Team
- 456 total downloads
- Latest version: 7.0.0-preview-1
PDFsharp is the Open Source library for creating and modifying PDF documents using .NET. It has an easy-to-use API that allows developers to generate or modify PDF files programmatically. PDFsharp can be used for various applications, including creating reports, invoices, and other types of documents.
This package does not depend on Windows and can be used on any .NET compatible platform including Linux and macOS.
See https://docs.pdfsharp.net for details.
See https://www.pdfsharp.com for professional support offers, premium technical advice, and contract work options.
Choose a support plan that suits your needs. We offer a variety of options, from small projects to large teams, with flexible response times.
Our team provides PDFsharp expert assistance, including implementation, optimization, and tailored solutions.
PInvoke.BCrypt
by: Andrew Arnott
- 389 total downloads
- Latest version: 0.7.124
P/Invoke methods for the Windows BCrypt.dll.
PInvoke.Kernel32
by: Andrew Arnott
- 379 total downloads
- Latest version: 0.7.124
P/Invoke methods for the Windows Kernel32.dll.
PInvoke.NCrypt
by: Andrew Arnott
- 376 total downloads
- Latest version: 0.7.124
P/Invoke methods for the Windows NCrypt.dll.
PInvoke.Windows.Core
by: Andrew Arnott
- 403 total downloads
- Latest version: 0.7.124
P/Invoke types for common Windows APIs.
PolyType
by: Eirik Tsarpalis
- 94 total downloads
- Latest version: 1.4.1
Practical generic programming for C#
Portable.BouncyCastle
by: Claire Novotny
- 359 total downloads
- Latest version: 1.9.0
BouncyCastle portable version with support for .NET 4, .NET Standard 2.0
Portable.BouncyCastle-Signed
by: Mark Junker
- 12 total downloads
- Latest version: 1.7.0.2
BouncyCastle.Crypto is a cryptography API providing:
-Generation and parsing of PKCS#12 files.
-X.509: Generators and parsers for V1 and V3 certificates, V2 CRLs and attribute certificates.
-PBE algorithms supported by PBEUtil: PBEwithMD2andDES-CBC, PBEwithMD2andRC2-CBC, PBEwithMD5andDES-CBC, PBEwithMD5andRC2-CBC, PBEwithSHA1andDES-CBC, PBEwithSHA1andRC2-CBC, PBEwithSHA-1and128bitRC4, PBEwithSHA-1and40bitRC4, PBEwithSHA-1and3-keyDESEDE-CBC, PBEwithSHA-1and2-keyDESEDE-CBC, PBEwithSHA-1and128bitRC2-CBC, PBEwithSHA-1and40bitRC2-CBC, PBEwithHmacSHA-1, PBEwithHmacSHA-224, PBEwithHmacSHA-256, PBEwithHmacRIPEMD128, PBEwithHmacRIPEMD160, and PBEwithHmacRIPEMD256.
-Signature algorithms supported by SignerUtilities: MD2withRSA, MD4withRSA, MD5withRSA, RIPEMD128withRSA, RIPEMD160withRSA, RIPEMD256withRSA, SHA-1withRSA, SHA-224withRSA, SHA-256withRSAandMGF1, SHA-384withRSAandMGF1, SHA-512withRSAandMGF1, SHA-1withDSA, and SHA-1withECDSA.
-Symmetric key algorithms: AES, Blowfish, Camellia, CAST5, CAST6, DESede, DES, GOST28147, HC-128, HC-256, IDEA, NaccacheStern, RC2, RC4, RC5-32, RC5-64, RC6, Rijndael, Serpent, Skipjack, TEA/XTEA, Twofish, and VMPC.
-Symmetric key modes: CBC, CFB, CTS, GOFB, OFB, OpenPGPCFB, and SIC (or CTR).
-Symmetric key paddings: ISO10126d2, ISO7816d4, PKCS#5/7, TBC, X.923, and Zero Byte.
-Asymmetric key algorithms: RSA (with blinding), ElGamal, DSA, ECDSA.
-Asymmetric key paddings/encodings: ISO9796d1, OAEP, and PKCS#1.
-Digests: GOST3411, MD2, MD4, MD5, RIPEMD128, RIPEMD160, RIPEMD256, RIPEMD320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, Tiger, and Whirlpool.
-Signer mechanisms: DSA, ECDSA, ECGOST3410, GOST3410, ISO9796d2, PSS, RSA.
-Key Agreement: Diffie-Hellman and EC-DH.
-Macs: CBCBlockCipher, CFBBlockCipher, GOST28147, HMac, and ISO9797 Alg. 3.
-PBE generators: PKCS#12, and PKCS#5 - schemes 1 and 2.
-OpenPGP (RFC 2440)
-Cryptographic Message Syntax (CMS, RFC 3852), including streaming API.
-Online Certificate Status Protocol (OCSP, RFC 2560).
-Time Stamp Protocol (TSP, RFC 3161).
-TLS/SSL Client with support for client side authentication.
Support for .NET 4, Windows Phone 8, Windows Phone App 8.1, Windows 8, Silverlight 5, MonoTouch, MonoAndroid
Portable.ConcurrentDictionary
by: Stef Heyenrath
- 29 total downloads
- Latest version: 1.0.4
This is a .NET Standard 1.0, .NET 2.0, .NET 3.5, Silverlight 5.0 and Windows Phone Silverlight 8.0 & 8.1 backport from System.Collections.Concurrent.ConcurrentDictionary as defined in .NET Core
Portable.System.DateTimeOnly
by: Oleg Rakhmatulin
- 153 total downloads
- Latest version: 9.0.2
DateOnly and TimeOnly types for .NET versions before 6.0
protobuf-net
by: Marc Gravell
- 998 total downloads
- Latest version: 3.4.30
Provides simple access to fast and efficient "Protocol Buffers" serialization from .NET applications
protobuf-net.Core
by: Marc Gravell
- 597 total downloads
- Latest version: 3.4.30
The protobuf-net serialization engine and build-time tooling; most projects should reference protobuf-net, which adds the runtime type model
PusherServer
by: Pusher
- 291 total downloads
- Latest version: 5.0.0
Pusher .NET library for interacting with the HTTP API